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Processing Basics
Notes



¥ This are notes. After finishing reading these notes, you should 

be able to:
¥ Create a new processing file

¥ Draw four primitive shapes: point, line, rectangle, and oval

¥ Set the sketch size.

¥ Add comments to your code

¥ Recognize that processing is case-sensitive and accepts free-form 

format.
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Submit Lab 1 together



COSC 123 – 5COSC 123 – 5

PDE: Creating and Running a Sketch
¥ To create a program code 

file, select File->New or 

¥ Your new program is called 
a sketch in Processing. 
Sketches are saved in a 
folder on your computer 
called sketchbook.

¥ To write your code, start 
typing in the Text Editor” 
area of the PDE. 

¥ Use the buttons Run and 
Stop on the toolbar to run or 
terminate your program.
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Primitive Shapes
¥ Example of primitive shapes

¥ Point: point(90,60);

¥ Line: line(50,10,70,20);

¥ Rectangle: rect(10,25,40,20);

¥ Ellipse: ellipse(50,70,40,20);

Function name Parameters
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Drawing Primitive Shapes
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Sketch Size
¥ To set the size of your sketch, use the size() function. For 

example, the following line sets the sketch width and height to 
400 and 200 pixels respectively. 

size(400,200);

200 
pixels

400 
pixels
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Sketch Size: Example 
¥ In the previous class, you wrote code to draw primitive shapes.

¥ The standard size of a sketch is 100x100 pixels

¥ The following program changes the size of the sketch to 
150x150.

// set sketch size to 150x150
size(150,150);

// draw shapes
line(50,10,70,20);
rect(10,25,40,20);
point(90,60);
ellipse(50,70,40,20);
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Sketch in Full Screen
¥ You can run your code in full screen using the function

fullScreen();

¥ You can choose only ONE of the two functions fullScreen() 
and size() in any program.

// sketch in full screen
fullScreen();

// draw shapes
line(50,10,70,20);
rect(10,25,40,20);
point(90,60);
ellipse(50,70,40,20);



Syntax Rules
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Syntax Rules: Comments
¥ Comments are used by the programmer to document and 

explain the code.  Comments are ignored by the computer.

¥ There are two choices for commenting:
¥ 1) One line comment: put “//” before the comment and any 

characters to the end of line are ignored by the computer.
¥ 2) Multiple line comment: put “/*” at the start of the comment and 

“*/” at the end of the comment.  The computer ignores everything 
between the start and end comment indicators.

¥ Example: /* This is a multiple line

comment.

With many lines. */

// Single line comment

// Single line comment again

line(10,10,20,20); // Comment after code
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More Syntax Rules
¥ To program in Processing you must follow a set of rules for 

specifying your commands.  This set of rules is called a syntax.

¥ Processing is case sensitive. 
¥ Line() is not the same as line().

¥ Processing accepts free-form layout.
¥ Spaces and line breaks are not important except to separate 

words.
¥ You can have as many words as you want on each line or spread 

them across multiple lines.
¥ However, you should be consistent and follow the programming 

guidelines given for assignments.
n It will be easier for you to program and easier for the marker to mark.

¥ You can use “Auto Format” PDE feature to rearrange your code in 
a more readable form
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Primitive Shapes, Text
Notes



¥ These are some notes for you to work on outside of class. After 

finishing these notes, you should be able to:
¥ Recognize and use primitive shape functions

n point(), line(), rect(), ellipse(), quad(), triangle(), bezier()

¥ Understand and specify shape coordinates
n i.e. specify the reference point or origin of a shape.

¥ Specify the attributes of drawing stroke.

¥ Write text on your sketch
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Drawing Primitive Shapes
¥ You learned before how to draw some of the primitive shapes, 

namely: point, line, ellipse, and rectangle. 

¥ There are other primitive shapes that we can also use such as: 
the quad, the triangle, and the Bezier line.
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Primitive Shapes

point(x,y)

(x,y)

ellipse(x,y,w,h)w

h
(x,y)

rect(x,y,w,h)

(x,y)

w

h
triangle(x1,y1,x2,y2,x3,y3)

(x1,y1)

(x2,y2) (x3,y3)

quad(x1,y1,x2,y2,x3,y3,x4,y4)

(x1,y1)

(x2,y2) (x3,y3)

(x4,y4)

bezier(x1,y1,cx1,cy1,cx2,cy2,x2,y2)

(x1,y1)

(x2,y2)
(cx2,cy2)

(cx1,cy1)

line(x1,y1,x2,y2)(x2,y2)

(x1,y1)
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Example

Primitive Shapes

quad(10,10,20,40,80,80,90,20);

ellipse(50,30,20,20);

triangle(50,40,25,75,75,75);

bezier(10,90,30,60,70,120,90,90);
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Defualt Shape Coordinates
¥ The default coordinates for rect and ellipse are:

rect(Top_Left_X, Top_Left_Y, Width, Height)

ellipse(Center_X, Center_Y, Width, Height)

àCORNER 

àCENTER

Width

H
ei

gh
t (X, Y)

(X, Y)

Width

H
ei

gh
t
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Specifying Shape Coordinates
¥ Default coordinates can be explicitly set to one of three modes:

¥ CENTER
(Center_X, Center_Y, Width, Height)

¥ CORNER
(Top_Left_X, Top_Left_Y, Width, Height)

¥ CORNERS
(Top_Left_X, Top_Left_Y, Bottom_Right_X, Bottom_Right_Y)

¥ The above applies to rect and ellipse but not necessarily to all shapes
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Specifying Shape Coordinates, cont’d
¥ You can change the mode using rectMode and ellipseMode

functions.

¥ Question: Can you link each statement to the right shape?

// set the sketch size

size(100,100);

// draw

rectMode(CORNER);    //this is the default mode

rect(20,20,30,30);

rectMode(CENTER);     //default is CORNER

rect(20,20,30,30);

rectMode(CORNERS);     //default is CORNER

rect(20,20,30,30);

200 40 60 80 100

80
10
0

60
40

20
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Stroke Attributes
¥ Stroke attributes are controlled by:

¥ strokeWeight(): Sets the width of the stroke in pixels. Takes one 
number (the width). Default is 1 pixel.

¥ strokeCap(): Sets the endpoints. Takes one parameter that can 
be ROUND, SQUARE, or PROJECT. Default is ROUND.

¥ strokeJoin(): Determines how line segments connect including the 
corners of any shape. Takes one parameter that can be MITER, 
BEVEL, or ROUND. Default is MITER.

strokeWeight(20);
strokeCap(ROUND);
line(20, 20, 80, 20); 
strokeCap(SQUARE);
line(20, 50, 80, 50); 
strokeCap(PROJECT);
line(20, 80, 80, 80); 

strokeWeight(10);
strokeJoin(MITER);
rect(10, 10, 30, 30); 
strokeJoin(BEVEL);
rect(10, 60, 30, 30); 
strokeJoin(ROUND);
rect(60, 60, 30, 30); 



Accept the GH Classroom Link on the 
course website: 

Canvas > Course Content > GitHub Classroom Links

Lecture Activity



COSC 123 – 24COSC 123 – 24

Lecture Activity Task

Draw Primitive Shapes
¥ Write code to draw the following sketches. Assume reasonable 

dimensions. 

(a) (b)

¥ Hint: sketch your drawing on paper first, try to figure out the 
coordinates, then write code
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See you on Friday!
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Drawing Text
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Drawing Text
¥ You can add text to your sketch using the following functions:

¥ textSize(20) changes the text size to 20

¥ text("Hello!", x, y) writes “Hello!” at (x,y)

¥ Use textAlign() to align the text. 
¥ Default is “left-bottom.

(x, y) Hello!

LEFT,BOTTOM alignment

Hello!

CENTER,CENTER alignment

Hello!

CENTER,TOP alignment



COSC 123 – 29COSC 123 – 29

Drawing Text
¥ You can also define a textbox so that text wraps inside it using 

the syntax

text("long text here",x,y,width,height)

n Note: width and height parameters are optional

¥ FONT 
¥ To change the font, you need two functions: loadFont() and 
textFont().

n More about this later

¥ COLOR
¥ To change the text color, use the fill function

n More about this later



COSC 123 – 30COSC 123 – 30

Example

size(140,120);
fill(0); // write in black

textAlign(CENTER);
textSize(28);
text("UBC", 70, 30);

textSize(18);
text("Okanagan", 70, 50);

textSize(12);
text("Computer Science", 70, 70);

textSize(10);
text("1177 Research Rd, Kelowna, BC V1V 1V7", 10,85,120,40);
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Git and GitHub Demo



PDE Features

Notes
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PDE Useful features
¥ Use Edit->Auto Format (or Ctrl+T) to automatically adjust 

code format to be more readable (i.e. indentation, spacing, etc.).
¥ Use Ctrl+/ to comment/uncomment a selected section of code. 
¥ Use Auto Compete (Ctrl+Space) to get code suggestions 

¥ enable from File->Preferences (next slide)

¥ Use the Color Selector (Tools->Color Selector…) to get the 
value of a color of your choice. 

¥ You can view many examples that demonstrate the different 
capabilities of Processing by going to File->Examples…

¥ You can add other files (images, fonts, documents, etc.) to use 
in your sketch from Sketch->Add File…
¥ This can also be done using your preferred file manager (e.g. 

Windows Explorer), but we will discuss this later.
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Code Completion
¥ It is recommended to use 

Code Completion feature. You 
can enable it by going to 
File->Preferences and 
check that option as shown in 
the figure.
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Sketchbook Tabs
¥ You can divide your 

code into several files 
managed by tabs for 
better structuring. 
¥ PDE arranges tabs 

alphabetically by 
their names.

¥ The code in all tabs 
will run as if it is in the 
same file.
¥ Tabs run from left to 

right.

¥ Examples:
¥ Put classes in tabs.
¥ Put your new 

functions in tabs.

Managing tabs: click on this arrow 
button to manage the tabs
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Processing Language Reference
¥ You can view a complete 

reference for the language using 
Help->Reference

¥ If you need help with specific 
keyword, highlight it then choose 
Find in Reference From the 
Help menu or the context menu.
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PDE Debugger
You can enable the debugging mode from the Debug menu or by 
clicking the Debugger icon    . 

Breakpoint: you can toggle breakpoints 
from the Debug menu or by clicking 
the line number.

Variables: you 
can observe 
how your 
variables 
change here

Debugger functions:
• Debug: run till the first 

breakpoint
• Continue: advance the 

code till the next 
breakpoint.

• Step: advance the code 
one line.

• Step Into: advance the 
debugger into the a
function call.

• Step Out: advance the 
debugger outside a 
function to the calling 
statement.
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ExerciseExercise

Using PDE Debugger to Trace Code
¥ Use the PDE Debugger to trace the following code. Notice the 

change in the x and y values.
¥ Step 1: Switch to Debugging mode
¥ Step 2: Put a breakpoint at the first line.
¥ Step 3: Click Run (Debug).
¥ Step 4: Step through your code

and observe the change in x,y and in
the console

No need to submit this to Canvas!!

2

int x, y = 20;
x = 10;
println("x: " + x);
println("y: " + y);
x = x + 3;
y = y + x;
println("x: " + x);
println("y: " + y);
println("The End!");
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Tips for Debugging Your Code
¥ Here are some tips that you may want to try when debugging 

your code:
¥ Trace changes in your variables.

n If you are not using the PDE Debugger, you can programmatically 
display the values of those variables related to your problem after they 
change. 

n You can use println() or text() functions to display the values. 
¥ Simplify your code.

n …using comments. Test segments of your code individually and see if 
they run as expected.

¥ Take a break! 
n Do something else or even go to sleep. When you come back, you 

might see what you weren’t able to see before.
¥ Get “someone” to look at your code.

n Fresh eyes might catch obvious mistakes that you aren’t able to see.



Accept the GH Classroom Link on the 
course website: 

Canvas > Course Content > GitHub Classroom Links

Lecture Activity
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Lecture Activity Task

Create A Character
¥ Write code to design a simple character: 

¥ We will use this character throughout the semester in 
other exercises. So, try to be creative! 

¥ No need to worry about the color at this point.

¥ Use the easiest drawing mode for aligning your body 
parts. 

n For example, it would be easier if we use the 
CENTER drawing mode for the torso.

¥ Include the following items:
n A belt (stroke with larger width)
n A logo on the character chest. 

¥ The design must have at least one character of text.

¥ Hint: sketch your drawing on paper first, try to figure 
out the coordinates, then write code
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Review of Primitive 
Shapes, Text
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The Notes
¥ Your notes for this week included discussion of:

¥ Primitive shape functions
n point(), line(), rect(), ellipse(), quad(), triangle(), bezier()

¥ Shape coordinates (origin)

¥ Stroke attributes

¥ Text



First:
¥ self-assess your understanding of the pre-class readings

Then:

1) Practice on primitive shapes and text
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QuestionQuestion

Shape Coordinates
The default coordinates for rectangles and ellipses are:

A. CORNER for both

B. CENTER for both

C. CENTER for rectangles, and CORNER for ellipses

D. CORNER for rectangles, and CENTER for ellipses

E. None of the above
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QuestionQuestion

Shape Coordinates
We can change the coordinates of a rectangle to CENTER using 
the statement:

A. coordinate(CENTER);

B. center();

C. rectMode(CENTER);

D. mode(CENTER);

E. CENTER;
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QuestionQuestion

Specifying Shape Coordinates
Which coordinate mode did we use here?

A. CORNER

B. CORNERS

C. CENTER

D. CENTERS

E. Other

size(100,100);

rectMode(?????);    

rect(40,40,50,50);
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QuestionQuestion

Stroke Attributes
We can change the width of the drawing stroke using the 
function:

A. width()

B. strokeWdith()

C. weight()

D. strokeWeight()

E. stroke()
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QuestionQuestion

Text
The statement to write “Hi” on the sketch at (50,50) is

A. write("Hi",50,50);

B. text("Hi",50,50);

C. text(50,50,"Hi");

D. writeText("Hi",50,50);

E. drawText("Hi",50,50);
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QuestionQuestion

Bezier shapes
Have you understood how bezier function work?

A. Yes

B. No

bezier(x1,y1,cx1,cy1,cx2,cy2,x2,y2)

(x1,y1)

(x2,y2)
(cx2,cy2)

(cx1,cy1)


